DRG 4.0

DRG National 4.0

versiune client-server

Aplicatia face parte din categoria aplicatiilor client-server, folosind Microsoft SQL Server 2000 ca sistem de gestiune a bazelor de date. Partea de interfata cu utilizatorul a fost dezvoltata folosind Visual Basic 6, avand la baza o arhitectura n-tier care asigura comunicarea eficienta intre utilizator si baza de date si permite accesarea bazei de date de catre un numar mare de utilizatori, simultan, fara afectarea performantelor aplicatiei.

Administrarea serverului de baze de date, pornind de la instalarea motorului SQL Server, MSDE 2000, si continuand cu configurarea acestuia (stabilire mecanisme de autentificare la server, setare conturi de login prin intermediul carora aplicatia poate accesa baza de date), adaugarea bazei de date DRG_2005 la acest server, crearea copiilor de siguranta a bazei de date, restaurarea bazei de date pornind de la diverse copii ale acesteia, posibilitatea de a rula fisiere script pe baza de date sunt procese care se efectueaza prin intermediul unei sectiuni ale aplicatiei, nefiind necesare decat cunostinte minime legate de aceste activitati.

Este indicat ca in fiecare spital sa existe o persoana cu notiuni de administrare retele care sa se ocupe si de efectuarea acestor procese cu functiuni administrative, care sa configureze aplicatia pe statiile de lucru conform indicatiilor din acest manual, sa creeze conturi de utilizator pentru persoanele care vor utiliza aplicatia si sa intervina in momentul in care apar disfunctionalitati in reteaua in care sunt plasate statiile de lucru care ruleaza aplicatia. La baza acestor disfunctionalitati ar putea sta unele mecanisme de securitate existente in retea (prezenta unui firewall pe calculatorul server de baze de date sau pe calculatorul care acceseaza prin intermediul aplicatiei serverul de baze de date) care ar duce la impiedicarea comunicatiei intre aplicatia client si serverul de baze de date (vezi operatia Instalare server si aplicatie).

Cerintele hardware sunt dictate atat de aplicatia in sine cat si de serverul de baze de date.

Astfel, calculatorul care va fi configurat sa functioneze ca server de baze de date va trebui sa fie dotat cu un procesor P4, 2GHz frecventa, memorie RAM 512 Mb, spatiu pe disc suficient pentru baza de date (discuri de capacitate 40 sau 80 Gb sunt frecevente pe piata, la preturi acceptabile si asigura si o viteza de transfer destul de buna). Sistemul de operare recomandat este Windows 2000 sau XP, cu un plus pentru primul.

Calculatoarele care vor rula aplicatia propriu-zisa se pot incadra in niste cerinte mai mici decat cele pentru serverul de baze de date, insa memoria RAM si procesorul ar fi bine sa se pastreze la valori apropiate de cele de mai sus. Pentru sistemul de operare folosit se poate opta si pentru sisteme de operare mai vechi (Windows 98, Windows Milenium). In plus, este necesara prezenta pe fiecare calculator care ruleaza aplicatia a unei variante de Internet Explorer versiune 6, care poate fi instalata daca este cazul de pe CD-ul de instalare al aplicatiei.

Aplicatia permite gestionarea informatiilor despre sectiile disponibile in spital, despre medicii afiliati spitalului respectiv si a foilor de observatie la nivelul spitalului in baza de date centrala situata pe server.
De asemenea permite generarea fisierelor de export necesar sa se transmita la Institutul National de Cercetare- Dezvoltare in Sanatate (INCDS ) si importul datelor dupa procesul de grupare si validare.

Este inclus un modern modul de raportare, care permite listarea rapoartelor necesare lunar, dar si exportarea acestora in diverse formate, inclusiv Excel si chiar Acrobat Reader (pdf-uri).


Instalare

Instalarea aplicatiei este un proces care presupune:

  1. instalarea motorului SQL Server 2000 care va gestiona baza de date (se lanseaza in executie fisierul MSDE_Installer.exe din directorul
    Radacina CD\Instalare aplicatie DRG National 4.0 (varianta Client-Server)\Instalare MSDE    );
  2. instalarea aplicatiei client prin intermediul careia se colecteaza date si se interogheaza baza de date (se lanseaza in executie fisierul setup.exe din directorul
    Radacina CD\Instalare aplicatie DRG National 4.0 (varianta Client-Server)\Instalare Aplicatie    ).

Instalare motor SQL Server 2000 Desktop. Aceasta operatie se executa doar pe calculatorul care va functiona ca server de baze de date.
Pentru spitalele care folosesc doar un singur calculator pentru colectarea datelor, pe acesta se va instala si serverul de baze de date prin intermediul acestei operatii si, ulterior, aplicatia client prin intermediul fisierului Setup.exe.

Imediat dupa lansarea in executie a fisierului MSDE_Installer.exe, se lanseaza in executie aceasta operatie care dureaza cca 3 sau 4 minute. Etapele pe care trebuie sa le parcurga utilizatorul care executa aceasta operatie sunt prezentate in continuare.

Imediat dupa lansare se deschide prima fereastra in care se face o prezentare a procesului care va avea loc. Utilizatorul trebuie sa apese butonul Inainte>, care are ca efect inchiderea acestei machete si deschiderea urmatoarei ferestre in care sunt afisate valorile parametrilor folositi pe parcursul instalarii (nume server, nume baza de date, informatii legate de autentificarea folosita).

De mentionat ca instanta de server de baze de date este una implicita (nume de instanta DEFAULT) ceea ce conduce la crearea unui server de baze date cu numele preluat din numele calculatorului.

Prin apasarea butonului Inainte> se va continua procesul de instalare, fiind afisata o fereastra care avertizeaza utilizatorul ca anumite portiuni din procesul de instalare sunt de mai lunga durata. Utilizatorul NU trebuie sa intrerupa procesul de instalare ci trebuie sa astepte incheierea sa, sau sa primeasca alt mesaj in timpul acestui proces.

Dupa apasarea butonului Inainte>, va incepe instalarea si configurarea instantei SQL Server 2000 Desktop, cu parametrii care au fost afisati mai sus.

Este foarte important in aceasta etapa, cea care dureaza cel mai mult, sa asteptati incheierea sa. Cele 9 secunde afisate cca 2 minute ar putea sugera blocarea aplicatiei, insa acest lucru nu se va intampla. Dupa incheierea sa, este anuntat utilizatorul cu privire la instalarea si configurarea serverului de baze de date.

Este foarte important de retinut urmatorul aspect. Este posibil ca in locul acestei ferestre sa apara alta care solicita utilizatorului restartarea calculatorului, imediat ce s-a incheiat instalarea si configurarea serverului de baze de date. Daca aceasta fereastra apare, se accepta restartarea calculatorului, iar dupa acest lucru se reia procesul de instalare al aplicatiei, ruland inca o data fisierul MSDE_Installer.exe. Acest lucru nu mai reia inca o data ceea ce s-a facut pana in acest moment, ci continua operatia de instalare din punctul in care s-a solicitat restartarea calculatorului. Daca pe parcursul etapei finale apare o eroare care termina procesul de instalare si configurare a serverului de baze de date, este necesara dezinstalarea aplicatiei Microsoft SQL Server Desktop Engine si reluarea operatiei de instalare si configurare server de baze de date, in acest caz nemaifiind necesara restartarea calculatorului, procesul finalizandu-se normal.

Ultimele operatii care au loc sunt scurte ca durata si in esenta au ca scop atasarea bazei de date DRG_2005 pe serverul creat si crearea unui cont prin intermediul caruia aplicatia client se conecteaza la baza de date. Dupa incheierea acestor ultime operatii, utilizatorul este anuntat ca procesul de instalare si configurare a serverului de baze de date si a bazei de date DRG_2005 s-a incheiat cu succes.

Se apasa butonul Termina si se poate considera incheiata aceasta operatie. In bara de stare a sistemului de operare se poate observa o pictograma sub forma [image] , care indica faptul ca cel putin o instanta a unui server de baze de date ruleaza pe calculatorul respectiv. Prin apasarea acestei pictograme folosind mouse-ul, se deschide fereastra

,

fereastra in care serverul NumeCalculator trebuie sa fie pornit (lucrul acesta se observa prin culoarea verde in dreptul pictogramei). De asemenea este indicat sa nu se debifeze controlul de selectie care permite ca la fiecare repornire a calculatorului serverul de baze de date sa porneasca automat.

Oprirea din rulare a serverului NumeCalculator impiedica aplicatia client DRG National 4.0 sa se conecteze la baza de date si o face inutilizabila. Acest lucru este indicat prin schimbarea culorii pictogramei din verede in rosu.

Din acest moment, orice calculator care ruleaza aplicatia DRG National 4.0, versiunea client-server, se poate conectala baza de date DRG_2005 de pe serverul instalat.

IMPORTANT: Numele serverului bazei de date instalat este NumeCalculator ("NumeCalculator" indica numele calculatorului pe care a fost instalat serverul de baze de date). Numele se poate identifica deschizand fereastra de mai sus si analizand informatia din campul Server (In acest caz MARIAN).

Dupa incheierea acestui proces trebuie verificat ca acest calculator pe care a fost configurat serverul de baze de date comunica pe portul 1433 folosit de aplicatia client pentru comunicare cu serverul de baze de date. Acest lucru este posibil lansand in executie consola de comenzi (Bara de programe\Run\cmd.exe) in care se lanseaza comanda netstat -na. In lista de informatii afisate se verifica daca este prezent portul 1433 afisat in dreptul protocolului TCP la adesa fizica a calculatorului, sau la adresa 0.0.0.0. Adresa fizica a calculatorului pe care a fost configurat serverul de baze de date se obtine lansand tot in cadrul consolei de comenzi comanda ipconfig, care va afisa o serie de informatii in care campul IP Address indica adresa fizica cautata. Faptul ca serverul de baze de date poate comunica se verifica in continuare folosind comanda telnet AdresaCalculator (sau NumeCalculator) 1433 in cadrul aceleiasi console de comenzi. Daca aceasta comanda se executa cu succes, consola se deschide sub o forma complet goala, indicand ca serverul de baze de date poate fi accesat. Daca aceasta comanda returneaza o eroare se verifica existenta unui firewall pe calculatorul in cauza care ar putea bloca acest lucru.

Instalarea aplicatiei client. Dupa instalarea si configurarea serverului de baze de date se poate instala si aplicatia client DRG_National 4.0. Aceasta aplicatie se poate instala atat pe alte calculatoare din reteaua in care functioneaza serverul de baze de date, cat si pe calculatorul pe care a fost configurat serverul de baze de date.

FOARTE IMPORTANT: Toate calculatoarele care ruleaza aplicatia client DRG National 4.0 trebuie sa aiba urmatoarele setari regionale astfel configurate:

  1. Formatul de tip "short date" pentru date calendaristice trebuie sa fie MM/dd/yyyy. Exemplu: 1 decembrie 2004 va fi reprezentat 12/01/2004.

  2. Formatul de tip "Numbers" pentru numere trebuie sa aiba proprietatea "decimal symbol" setata la ".", iar proprietatea "digit grouping symbol" setata la ",". Exemplu de numar reprezentat astfel: 3,456,789.00

  3. Formatul de tip "Currency" pentru numere trebuie sa aiba proprietatea "decimal symbol" setata la ".", iar proprietatea "digit grouping symbol" setata la ",". Exemplu de numar reprezentat astfel: $3,456,789.00

Nerespectarea acestor proprietati face imposibila sau eronata functionarea anumitor module ale aplicatiei.

Pentru lansarea in executie a procesului de instalare a aplicatiei se foloseste fisierul setup.exe din directorul
Radacina CD\Instalare aplicatie DRG National 4.0 (varianta Client-Server)\Instalare Aplicatie).

Instalarea aplicatiei este un proces foarte usor de gestionat. Pe parcursul acestei operatii utilizatorul trebuie doar sa apese pe butonul Continua, ori de cate ori acesta apare, respectiv pe butonul Instalare aplicatie, pentru a porni procesul de copiere a fisierelor pe calculatorul in cauza.

Instalarea aplicatiei este configurata implicit sa se efectueze in directorul C:\Program Files\DRG4, si nu trebuie modificata aceasta cale atunci cand este permis, deoarece este necesara astfel si reconfigurarea fisierului de initializare a aplicatiei, pentru a tine cont de aceste modificari.

Pe parcursul acestei operatii este posibil ca unele fisiere care se vor copia pe calculator sa fie deja prezente pe acesta. In acest caz, daca versiunea de pe calculator a fisierului este mai noua decat cea in curs de copiere este afisat un mesaj pe parcursul operatiei in care se solicita pastrarea versiunii de pe calculator, lucru care trebuie facut.

Operatia este de scurta durata si nu ar trebui sa creeze probleme utilizatorilor. Aceasta aplicatie a fost testata din punct de vedere al functionarii sale pe calculatoare avand sisteme de operare Windows 2000 sau Windows XP, dar teoretic ar trebui sa functioneze si pe calculatoare cu sisteme de operare mai vechi.

Daca este nevoie, nu uitati sa actualizati varianta de Internet Explorer prezenta pe calculatoare la versiunea 6.X, folosind in acest scop aplicatiile de actualizare prezente pe CD-ul de instalare. Fara aceasta operatie, acolo unde este necesar, aplicatia nu va functiona.

Dupa terminarea operatiei de instalare a aplicatiei se poate lansa in executie aceasta, folosind zona de programe sistemului de operare, alegand grupul de programe DRG4, fisierul DRG4.exe, singurul impediment in functionarea sa fiind nefunctionarea serverului de baze de date (oprit, neinstalat, sau nespecificat numele sau corect), sau faptul ca aplicatia nu poat comunica cu serverul de baze de date pe portul 1433. In cazul in care apare un mesaj de eroare care indica aparitia unui probleme de comunicare intre calculatorul pe care ruleaza aplicatia si serverul de baze de date, este necesar sa se verifice si de pe acest calculator comunicarea cu serverul pe portul specificat mai sus, folosind comanda telnet NumeCalculatorServer (sau adresa server) 1433. Succesul executiei acestei comenzi asigura posibilitatea de a folosi aplicatia de pe acel calculator.


Introducere

Lansarea in executie a aplicatiei

Imediat dupa lansarea in executie a aplicatiei se afiseaza o interfata care afiseaza valorile setate pentru numele serverului bazei de date si pentru baza de date la care se va conecta aplicatia. Acesti parametrii sunt setati la valori predefinite in timpul instalarii aplicatiei. Numele bazei de date este setat corect, insa nu se poate cunoaste la momentul instalarii aplicatiei numele serverului.
Numele serverului de baze de date este dat de numele calculatorului care va functiona ca server. Acest nume trebuie completat corect, doar la prima lansare in executie a aplicatiei, la urmatoarele utilizari aplicatia pastrand acest nume.

Dupa setarea parametrului "Nume Server" sau dupa acceptarea valorii afisate, sunt efectuate o serie de verificari interne care testeaza existenta serverului si a bazei de date pe acest server.

Fig1. Macheta Configurare parametrii necesari functionarii aplicatiei (nume Server si baza de date)

In cazul in care serverul de baze de date nu este configurat sau exista probleme de retea care nu permit aplicatiei de pe alt calculator sa acceseze calculatorul server, va fi afisat un mesaj de eroare care indica acest lucru. In aceasta situatie aplicatia se va inchide automat. Puteti efectua verificari privind comunicarea cu serverul de baze de date, verificari care au fost prezentate in sectiunea Instalare server si aplicatie).

Daca serverul de baze de date a fost recunoscut, aplicatia continua sa se execute, afisand fereastra sa principala.


Setare utilizator

Setare utilizator curent

Prima operatie care trebuie efectuata dupa aparitia ferestrei principale a aplicatiei este specificarea utilizatorului curent al acesteia.
Exista doua categorii de utilizatori ai aplicatiei: "Admin" si "User". Utilizatorul implicit "DRG_Admin" poate efectua orice operatie disponibila in aplicatie. Utilizatorii adaugati ulterior, din categoria "User" pot doar completa foi de observatie si rula rapoarte interne.

Configurarea informatiilor care tin de spitalele si sectiile de lucru precum si informatiile despre medici sunt operatii care se executa doar de utilizatorul "DRG_Admin". De asemenea operatiile "Export catre biroul DRG" si "Import coduri DRG" sunt permise doar pentru acest utilizator.
In plus toate operatiile de adminsitrare baza de date pot fi efectuate doar de acest tip de utilizator.

Fig1. Macheta Setare utilizator curent

Utilizatorul se alege din lista cu utilizatorii disponibili ai aplicatiei. Aceasta lista va afisa toti utilizatorii disponibili, in urma operatiei de gestionare a utilizatorilor, operatie efectuata de administratorul aplicatiei.
Parola se introduce de la tastatura, avand grija la starea tastei CAPS, conform intelegerii dintre utilizator si adminsitrator cu privire la valoarea acesteia.

Daca informatiile de autentificare nu sunt corecte nu se realizeaza accesul la functiile principale ale aplicatiei, fiind afisat si un mesaj de avertizare in acest sens.

Dupa aceasta operatie se obtine accesul la functiile aplicatiei, acces setat in functie de tipul de utilizator ("Admin" sau "User"). In plus aceste informatii (Nume de utilizator si tip de utilizator) sunt afisate si in bara de stare a aplicatiei. In orice moment se poate opta pentru alegerea altui utilizator de lucru, fara sa fie nevoie sa se inchida aplicatia. Singura conditie este inchiderea tuturor celorlalte machete ale aplicatiei. Acest lucru ar putea fi necesar daca doi operatori utilizeaza, pe rand, aplicatia instalata pe aceeasi masina.


Date colectate in aplicatie

Colectarea datelor prin intermediul acestei aplicatii presupune completarea unor informatii in mai multe tipuri de controale de editare: de tip text, numeric, data (si eventual ora) calendaristica, control de selectie valori, lista, sau de tip tabel.
Accesul la aceste controale este permis fie cu mouse-ul, fie cu tasta Enter, fie cu tasta Tab. Se recomanda folosirea tastei Enter in acest scop, deoarece apasarea repetata a acestei taste conduce la pozitionarea operatiei de editare exact in controalele prevazute in acest scop, si in plus, dupa completarea cu informatie a unui control, asigura activarea corespunzatoare a butoanelor de transmitere informatii in si din baza de date (butoanele Salveaza, Renunta, Cauta, Adauga, Sterge, Iesire).

  1. Colectare informatii prin intermediul controalelor de tip text

  2. Colectare informatii prin intermediul controalelor de tip numeri c

  3. Colectare informatii prin intermediul controalelor de tip data calendaristica

  4. Colectare informatii prin intermediul controalelor de selectie valori

  5. Colectare informatii prin intermediul controalelor de tip selectie din lista

  6. Colectare informatii prin intermediul controalelor de tip tabel

  • Colectare informatii prin intermediul controalelor de tip text: se completeaza fiecare control de acest tip cu datele necesare, respectand particularitatile informatiilor completate (lungimea maxima permisa, acolo unde este specificata). Acest tip de control nu ar trebui sa ridice probleme deosebite utilizatorilor.

Fig1. Control de tip text pentru completare informatii

  • Colectare informatii prin intermediul controalelor de tip numeric: se completeaza fiecare control de acest tip cu datele necesare, respectand particularitatile informatiilor completate (valoarea maxima permisa, acolo unde este specificata). In cadrul acestor controale este permisa numai folosirea caracterelor numerice, orice incercare de a introduce un caracter de alt tip esuand. Controalele de acest tip sunt identificate foarte usor, prezentand cifra 0 ca valoare implicita.
    Acest tip de control nu ar trebui sa ridice probleme deosebite utilizatorilor.

Fig2. Control de tip numeric pentru completare informatii

  • Colectare informatii prin intermediul controalelor de tip data calendaristica: se completeaza fiecare control de acest tip cu datele necesare, respectand particularitatile informatiilor completate. Acolo unde este cazul acest control afiseaza si permite si setarea informatiilor despre timp, in formatul ora:minute (doar data si ora internare, respectiv data si ora externare permit acest lucru). Implicit, aceste controale nu sunt completate cu nici un fel de informatie. Ele pot fi recunoscute usor prin prezenta checkbox-ului de selectie in partea lor stanga.
    Printr-o apasare cu mouse-ul in dreptul checkbox-ului din partea stanga a acestui control, este setata ca valoare a acestui control ziua curenta. Prin inca o apasare pe acest checkbox, se obtine golirea controlului de orice informatie.
    Daca valoarea afisata nu este cea dorita, se poate apasa pe butonul de selectie data din partea dreapta care va afisa un calendar cu zilele din luna curenta, utilizatorul putand selecta astfel ziua dorita. Calendarul ofera posibilitatea de a schimba luna afisata prin cele 2 butoane (stanga si dreapta), oferind posibilitatea selectarii unei date din alta luna.
    Informatia din aceste controale poate fi completata si direct prin editare, pozitionand mouse-ul pe sectiunea dorita si modificand valoarea. Editarea acestui tip de control este permisa doar daca este afisata o informatie in control.

Fig3.1. Control de tip data calendaristica pentru completare informatii

Fig3.2. Control de tip data calendaristica pentru completare informatii folosind calendarul

  • Colectare informatii prin intermediul controalelor de selectie valori: sunt utilizate pentru a completa informatiile despre diagnostice si proceduri. Aceste informatii se pot completa direct prin editare, in cazul in care este cunoscut codul procedurii sau al diagnosticului, sau se poate folosi butonul de selectie din partea stanga pentru a deschide o forma de selectie prin intermediul careia sa se selecteze diagnosticul sau procedura dorite.
    In cazul in care a fost completat manual un cod de diagnostic, iar acest diagnostic nu se regaseste in baza de date nu este afisata denumirea in dreptul codului sau, si va fi generat si un mesaj de eroare in momentul salvarii foii de observatie.
    Forma de selectie folosita permite specificarea unui criteriu care sa ajute la identificarea procedurii sau a diagnosticului cautate.

    Fig4.1. Control de tip selectie pentru completare informatii

    Pentru diagnostice forma de selectie se prezinta astfel:

    Fig4.2. Forma de selectie diagnostice

    Cautarea decurge astfel.
    Se poate specifica un criteriu mai complex format din clasa diagnosticului (obligatoriu se face cautare intr-o anumita clasa de diagnostice), subclasa diagnosticului (se poate face cautare printr-o anumita subclasa sau prin toate subclasele) din clasa specificata, codul diagnosticului din clasa (normal este sa nu se specifice nimic, deoarece se presupune ca acest cod este necunoscut) si o valoare care se regaseste in denumirea diagnosticului, in campul Diagnostic. Cautarea in baza de date a diagnosticelor care indeplinesc acest criteriu afiseaza diagnosticele din clasa specificata, subclasa selectata (toate subclasele, daca s-a selectat valoarea *******Toate*******), si care contin in denumirea diagnosticului valoarea completata. Acest criteriu este identificat pe macheta de selectie si vizual, folosindu-se culoarea galbena.
    Se poate opta pentru o cautare avansata a diagnosticelor in baza de date, specificand un sir de cuvinte in controlul Diagnostic (cautare avansata). Sunt afisate diagnosticele care contin oricare din cuvintele specificate, in orice pozitie in cadrul campului Denumire Diagnostic.
    Odata identificat diagnosticul in lista, prin dublu-click pe acesta se obtine incarcarea acestuia in controlul de selectie, operatie urmata si de afisarea denumirii acestuia pe interfata principala.

    Pentru completare proceduri se aplica acelasi principiu, singura diferenta constand in modificarea formei de selectie.

  • Colectare informatii prin intermediul controalelor de tip selectie din lista: se completeaza fiecare control de acest tip cu datele necesare, alegand din lista pusa la dispozitie o valoare dorita. Nu este permisa completarea in acest control a unor valori care nu sunt in lista.
    Acest tip de control nu ar trebui sa ridice probleme deosebite utilizatorilor.

    Fig5. Control de tip selectie din lista pentru completare informatii

  • Colectare informatii prin intermediul controalelor de tip tabel: ajuta la completarea informatiilor despre proceduri, diagnostice secundare si transferurile dintre sectii.
    Utilizarea lui ar putea ridica o serie de probleme, de aceea intelegerea modului de completare a informatiilor prin intermediul sau este foarte importanta. Urmatoarele aspecte trebuie retinute:

    • fiecare coloana a tabelului identifica tipul de informatie si modul de completare a informatiei pe liniile coloanei in cauza. Astfel in functie de acest lucru, completarea cu informatii in fiecare celula se face prin intermediul unor controale de tip "selectie din lista", de "selectie valori", de tip "data calendaristica", de tip "numeric" sau de tip "text" (de exemplu: toate celulele tabelului din coloana Sectie se vor completa alegand o sectie din lista de sectii ce se afiseaza in dreptul celulei odata cu apasarea prin dublu-clik cu mouse-ul pe celula respectiva, toate celulele tabelului din coloana Data Internare se vor completa editand controlul de tip "data calendaristica" case se afiseaza in dreptul celulei odata cu apasarea prin dublu-clik cu mouse-ul pe celula respectiva etc).

    • tabelul este prevazut cu o linie care permite completarea informatiilor care tin de prima linie din setul de linii;

    • imediat ce o celula de pe o linie a fost editata, se activeaza 2 din cele 3 butoane din partea dreapta, sus a tabelului. Acestea permit adaugarea unei noi linii in tabel in vederea completarii sale cu informatie, sau stergerea unei linii care contine informatie in ea. O linie marcata ca stearsa nu este eliminata din tabel, avand un marcaj sub forma unei linii rosii, putandu-se revenii ulterior asupra stergerii prin butonul "Revenire asupra stergerii liniei selectate", care devine activ imediat ce linia curenta este marcata ca stearsa.

    • o linie marcata ca stearsa nu mai permite editarea informatiilor.

    • toate editarile care se fac in tabele nu se transfera automat si in baza de date. In schimb se ofera posibilitatea salvarii informatiilor in baza prin intermediul butoanelor "Salveaza" sau "Renunta".

Fig6. Control de tip tabel pentru completare informatii

Fig7. Control de tip tabel in momentul completarii cu informatii

Fig8. Control de tip tabel cu o linie marcata ca stearsa


Flux date

Fluxul datelor de la colectare pana la transmiterea lor catre INCDS

Traseul datelor intre locul de colectare si INCDS trebuie sa fie cat se poate de coerent si de bine inteles de catre orice persoana implicata in oricare din etapele colectarii datelor.

Acest traseu cuprinde la nivelul spitalului urmatoarele etape:

1. Colectarea datelor se face intr-o baza de date centralizata la nivelul spitalului, folosind in acest scop aplicatia instalata intr-o retea de calculatoare. Aceasta baza de date poate fi interogata prin intermediul rapoartelor de pe orice calculator care ruleaza aplicatia.

2. Transmiterea datelor din baza de date centrala catre INCDS se va efectua folosind meniul « Transfer Date/ Export cu criptare catre INCDS». Fisele selectate conform criteriilor de export vor fi exportate catre o baza de date « DRGExport_data_ora.mdb » care va fi salvata in catalogul EXPORT prezent in directorul in care a fost instalata aplicatia. Acest fisier se va redenumi in felul urmator: « DRGExport_CodSpital_an_luna_zi.mdb ». Operatia este disponibila doar utilizatorului cu drept de administrare. Numele si prenumele pacientului nu sunt preluate in acest fisier, in timp ce restul datelor confidentiale prezente in fisierul exportat (CNP pacient si coduri parafa medici) sunt incriptate, incat sa piarda orice legatura deductibila cu informatiile reale. In acest mod este respectat dreptul pacientului la secretul diagnosticului si a actului medical, numele sau real sau orice alta informatie care sa-l poata identifica ramanad la nivelul spitalului, care este oricum raspunzator pentru pastrarea confidentialitatii.

3. Transmiterea fisierului generat se face prin intermediul unei aplicatii de e-mail. Acest fisier va fi suplimentar incriptat, datorita caracterului nesigur a informatiei ce circula liber in Internet. Procedura de incriptare in acest caz este de tip cheie publica-cheie privata de 2048 bits, cea mai puternica si sigura tehnologie de incriptare software a momentului.

La nivelul INCDS datele primite prin e-mail de la toate spitalele implicate in proiect sunt centralizate, analizate si apoi introduse in grouper, pentru calcularea codului DRG.

Schematic, acest proces se prezinta astfel:


Instalare PGP

Instalarea si configurarea programului PGP

PGP este un program extrem de puternic folosit pentru incriptarea si autentificarea datelor si va fi instalat numai pe computerul destinat transmiterii datelor prin e-mail. Folosirea sa este obligatorie datorita cerintelor de securitate a datelor confidentiale despre pacienti la tranzitul prin medii nesigure, cum este Internetul.

Versiunea sa freeware acopera toate cerintele programului DRG, nu implica achizitionarea vreunei licente de orice fel din partea spitalului si se gaseste pe CD-ROM livrat, in directorul Utile\PGP V.6.5.3. Principiul de functionare al programului PGP (Pretty Good Privacy – confidentialitate la un nivel destul de bun, in traducere libera) nu face obiectul acestui ghid, dar poate fi cu usurinta regasit in help-ul sau.

Etapele necesare instalarii vor fi explicate pas cu pas in cele ce urmeaza:

  1. Lansati executabilul setup.exe din directorul Utile\PGP V.6.5.3. In scurt timp va aparea interfata de instalare proprie a programului.
  2. La mesajul sau de intampinare (Welcome) selectati Next pentru a contiua instalarea

  3. Apasati Yes in fereastra de acceptare a conditiilor de licentiere.

  4. In fereastra cu prezentarea ultimilor noutati despre acest program, apasati Next

  5. Completati in campul Company numele spitalului Dvs. Introducerea unui nume in campul Name este optionala. Pentru a trece mai departe, apasati Next

  6. Fereastra urmatoare va solicita calea de instalarea a programului. Implicit aceasta este C:\Program Files\Network Associates\PGP. Daca nu exista motive imperioase de a schimba aceasta cale, va sugeram sa o lasati pe cea propusa de program. Atentie: in cazul in care computerul Dvs este conectat in retea, ar trebui ca directorul in care se instaleaza programul PGP acesta sa nu aiba atributul sharing activat, pentru a nu avea nimeni altcineva acces la cheia Dvs. privata. Pentru continuare apasati Next.

  7. In urmatoarea fereastra selectati componentele programului ce doriti sa fie instalate. Pentru necesitatile DRG, indiferent de ce va propune programul, pastrati numai urmatoarele componente:
    1. PGP Key Management
    2. PGP Microsoft Outlook Express Plugin (sau cel corespunzator programului de e-mail instalat pe sistemul Dvs. In acest ghid va fi detaliata insa numai varianta pentru Outlook Express, deoarece acesta este gratuit instalabil in majoritatea versiunilor de Windows)
    3. Optional PGP User’s Guide

Dupa ce ati selectat corect componentele, apasati Next pentru a continua.

  8. Dupa fereastra in care revedeti optiunile de instalare selectate (de care treceti simplu cu Next), urmeaza instalarea propriu-zisa. Instalarea programului este practic incheiata, urmand etapa de generare a cheilor de incriptare. Apasati pe No la intrebarea programului daca aveti chei pre-existente ce doriti sa le utilizati.

Ultima fereastra din programul de instalare va permite sa lansati si asistenul de generare a cheilor. Apasati butonul Finish.

Treceti peste prima fereastra din programul asistent apasand Next si veti ajunge in fereastra de introducere a datelor de identitate a spitalului Dvs. Este esential ca aici sa introduceti corect titulatura spitalului Dvs si adresa de e-mail a acestuia. Dupa cum am mentionat mai sus la cerinte de sistem, este necesar sa aveti un cont de e-mai de tip POP3. Dupa completarea corecta, apasati Next.

Urmatoarea intrebare a programului se refera la algoritmul ce se doreste a fi folosit in generarea cheilor. Lasati optiunea sugerata de program (Diffie-Hellman/DSS) si apasati Next.

Lungimea cheii va putea fi aleasa in sectiunea urmatoare. Cu cat cheia este mai mare, cu atat incriptatea va fi mai puternica, in defavoarea insa a vitezei de lucru. Consideram ca pentru scopul DRG sugestia programului (2048 bits) mentine un raport optim (putere incriptare)/(viteza lucru). Pastrati asadar aceasta valoare si apasati Next

Cheile generate pot avea un “termen de valabilitate”, facilitate pe care nu intentionam (cel putin deocamdata) sa o folosim. Lasam deci bifat Key pair never expires si continuam cu Next.

Fereastra ce urmeaza este extrem de importanta. In ea veti introduce parola pentru activarea cheii voastre secrete. Deconspirarea acesteia poate compromite securitatea datelor. Nu alegeti o parola usor intuibila. Lungimea sa minima recomandabila este de 8 caractere, acestea putand fi de orice tip: litere majuscule/minuscule, cifre, caractere speciale (~!@#$%^&*{}[]<>?”:;\), spatiu. Scrieti aceasta parola in campul de sus si apoi, pentru confirmare, si in cel de jos.

Atentie:

Daca Hide typing este bifat, nu veti vedea nimic din ce scrieti, deci va trebui sa o faceti cu multa grija. Cu cat parola introdusa este mai mare si mai complexa, cu atat mai sus va ajunge cursorul in zona Passphrase Quality. Cand ati terminat de scris, apasati Next.

Programul va genera un set de chei, operatiune ce dureaza cu atat mai mult cu cat computerul Dvs. este mai modest in performante. La terminarea operatiunii, va afisa urmatoarea fereastra, din care treceti mai departe cu Next.

Acum nu mai trebuie decat sa apasati Next in fereastra ce va aparea, avand grija ca optiunea Send my key to the root server now sa nu fie bifata.

Astfel am ajuns si la ultima fereastra din program. Apasati butonul Finish

Va aparea sectiunea din prgramul PGP ce se ocupa de managementul cheilor de incriptare. Ar trebui sa vedeti ceva in genul urmatoarei imagini, cu mentiunea ca titulatura spitalului Dvs si adresa sa corecta de e-mail vor aparea aici.

Pentru a evita eventuale confuzii, puteti renunta la cheile publice ale angajatilor ce au lucrat la PGP (ce nu folosesc deloc programului DRG), procedand astfel:

Ø selectati toate cheile publice folosind combinatia de taste Ctrl+A.

Ø deselectati apoi numai cheia spitalului Dvs., facand click cu mouse-ul pe ea, in timp ce tineti in continuare apasata tasta Ctrl

Ø apasati tasta Delete si confirmati stergerea cu Yes to All

Dupa aceasta operatiune, imaginea ar trebui sa arate in felul urmator:

Urmatoarea etapa consta in importarea cheii publice a INCDS.

Pentru importarea chei publice a INCDS(apare ca ‘Centrul DRG – Bucuresti’) in programul PGPkeys, apasati combinatia de taste Ctrl+M. In meniul de import ce apare, schimbati calea pana la CD-ROM-ul DRG, in directorul PGP, unde se gaseste fisierul
Centrul DRG - Bucuresti.asc. Selectati-l si apasati Open, apoi Import. Daca totul a decurs corect, PGPkeys va arata in modul urmator:

Faptul ca adresa de e-mail care apare ca fiind a INCDS (‘Centrul DRG – Bucuresti<drg@ms.ro>’) este drg@ms.ro, si nu dateclinice@drg.ro care este adresa reala, nu are nici o importanta, nu s-a putut genera o alta cheie pentru pastrarea validitatii cheii cu care lucreaza deja niste spitale.

Cu acestea, instalarea si configurarea programului PGP s-a incheiat cu succes. Procedurile de incriptare a fisierului cu date pacienti si semnare a e-mail-ului vor fi descrise in cadul operatiei Transfer date catre INCDS


Transfer date

Transferul datelor catre INCDS

Transmiterea datelor la INCDS se va face in mod obligatoriu pana la data de 5 a lunii curente, indiferent de volumul de date colectat pana in acel moment.

Pentru a realiza cu succes operatiunea de transmitere, trei operatiuni sunt necesare:

  1. exportul datelor colectate
  2. incriptarea si semnarea acestei baze de date
  3. atasarea ei la un e-mail si semnarea acestuia

In continuare, vom detalia modul de incriptare si semnare a unui fisier, in particular pe cel contine baza de date pacienti ce trebuie trimisa la INCDS.

Principalele momente sunt:

  1. lansati Windows Explorer si localizati fisierul DRGExport_CodSpital_an_luna_zi.mdb (se gaseste in catalogul EXPORT din directorul in care este instalata aplicatia DRG4.0, unde l-ati salvat prin export si unde l-ati redenumit)
  2. faceti click pe el cu butonul drept al mouse-ului si in meniul contextual ce apare, selectati sectiunea PGP, iar in interiorul acesteia Encrypt & Sign
  3. va aparea urmatoarea fereastra, in care faceti dublu-click pe cheia Centrului DRG, aceasta trecand in campul Recipients, dupa care apasati OK.
  4. fereastra urmatoare va solicita parola de la cheia Dvs privata, pentru a putea semna fisierul. Daca Hide Typing este bifat, nu veti vedea ce tastati.

  5. acum programul PGP are toate datele necesare operatiunii. El va crea un fisier cu aceeasi denumire dar cu extensia .pgp, in acelasi director cu fisierul sursa.

Etapa urmatoare (si ultima) consta in atasarea acestui fisier la un e-mail. In acest ghid, vom detalia numai modul de lucru cu Microsoft Outlook Express. Pentru celelalte programe de e-mail, procedura este similara.

Pasii de urmat sunt:

  1. lansati clientul de e-mail
  2. compuneti un nou mesaj
  3. completati adresa de e-mail a INCDS destinata exclusiv colectarii datelor de la spitale: dateclinice@drg.ro.
  4. in corpul mesajul completati numele persoanei ce s-a ocupat cu operatiunea de import si modalitatile de a intra in contact du ea (telefon, e-mail)
  5. atasati la mesaj fisierul incriptat si semnat DRGExport_CodSpital_an_luna_zi.mdb.pgp, obtinut in etapa anterioara
  6. semnati mesajul, apasand pe iconita PGP (ce apare in icon bar) si selectand Sign
  7. trimiteti mesajul
  8. in functie de tipul conexiuni Dvs la Internet, mesajul va fi trimis imediat (daca aveti o conexiune permanenta) sau dupa ce va conectati (daca este o conexiune de tip dial-up).


Date

Date colectate in aplicatie

Colectarea datelor prin intermediul acestei aplicatii se face utilizand meniul Date.

  • Gestionarea spitalelor pentru care se colecteaza date (meniul Date\Setare lista spitale).
    Vezi operatia Setare spitale.
  • Gestionarea sectiilor din spitalele pentru care se colecteaza date (meniul Date\Setare lista sectii).
    Vezi operatia Setare sectii.
  • Gestionarea medicilor din spitalele pentru care se colecteaza date (meniul Date\Setare lista medici).
    Vezi operatia Setare medici.
  • Colectare foi de observatie clinica generala (meniul Date\FOCG).
    Vezi operatia Evidenta FOCG .


Setare spitale

Gestionarea spitalelor pentru care se colecteaza date

Informatiile legate de spitalele pentru care se colecteaza date se gestioneaza prin intermediul acestei operatii. Inainte de a se incepe colectarea foilor de observatie este necesara efectuarea acestei operatii.

In mod normal, in fiecare spital se colecteaza date aferente acestuia, deci numarul spitalelor pentru care se colecteaza date nu ar trebui sa fie mai mare de 1. Insa, avand in vedere ca pot exista spitale care au sectii exterioare identificate prin alt cod de spital (cod de 6 caractere INCDS), iar la nivel local este necesara evidenta distincta a foilor de observatie, se pot seta si doua sau mai multe spitale de lucru cu aceasta aplicatie.

Denumirea spitalelor si codul acestora nu se completeaza la nivelul spitalelor, ci se aleg dintr-o lista care contine toate spitalele, codificate atat dupa sistemul CNAS cat si INCDS. Singura informatie care poate fi specificata pentru eventuale analize la nivel local este numarul paturilor la nivelul spitalului.

Manipularea spitalelor de lucru trebuie sa respecte o serie de reguli:

  • Nu se poate insera in baza de date acelasi spital de mai multe ori;
  • Nu se poate sterge un spital de lucru pentru care s-au setat sectii si medici;
  • Un spital de lucru odata setat poate fi modificat atat timp cat nu au fost setate sectii sau medici, alegand in locul lui alt spital, doar daca noul spital ales nu exista deja specificat.

Nerespectarea acestor reguli este soldata cu aparitia unui mesaj de eroare care identifica eroarea comisa.

Macheta pentru manipularea acestor informatii se prezinta astfel

Fig1. Macheta Selectie/Adaugare/Editare/Stergere informatii spitale selectate

In momentul deschiderii sale, macheta este pregatita pentru efectuarea a doua operatii distincte:

  1. Adaugarea de informatii noi, prin completarea controalelor de editare disponibile (controalele "gri" sunt dezactivate, fiind completate automat in momentul selectarii unui spital din lista).
  2. Cautarea in baza de date a informatiilor legate de spitalele deja setate (click pe butonul Cauta...).

Daca s-a optat pentru prima operatie, imediat dupa completarea unui control cu informatie, se dezactiveaza posibilitatea de cautare in baza, butonul Cauta... devenind inactiv. In schimb devin active butoanele Salveaza si Renunta, oferind utilizatorului posibilitatea de a salva datele nou introduse (click pe butonul Salveaza) sau de a renunta la introducerea acestor date (click pe butonul Renunta). Salvarea datelor in baza de date va avea loc daca nu sunt incalcate regulile specificate mai sus.
Inainte de a opta pentru una din cele doua posibilitati, macheta se prezinta astfel

Fig2. Macheta Selectie/Adaugare/Editare/Stergere informatii spitale inainte de Salvare|Renuntare

Daca s-a optat pentru renuntarea la informatiile introduse, macheta revine la starea initiala din figura 1.
Daca s-a optat pentru salvarea informatiilor in baza, iar aceste informatii au fost salvate cu succes, macheta trece intr-o noua stare prezentata mai jos.

Fig3. Macheta Selectie/Adaugare/Editare/Stergere informatii spitale dupa salvarea datelor

In acest moment se poate opta pentru setarea altor spitale ca spitale de lucru, adaugandu-le in baza de date (butonul Adauga...; macheta de informatii revine la starea din figura 1, pregatita pentru adaugare), se poate opta pentru stergerea acestui spital setat ca spital de lucru (butonul Sterge; inainte de stergerea propriu-zisa a spitalului din baza de date se solicita inca o data confirmarea acestei operatii, avand in vedere ca se poate apasa din greseala pe acest buton, iar stergerea datelor este o operatie asupra careia nu se mai poate reveni), se poate opta pentru editarea datelor afisate pe ecran (modificand valorile din controalele de editare disponibile - imediat dupa modificarea valorilor se activeaza din nou optiunile de salvare | renuntare care de aceasta data au semnificatia de salvare a modificarilor efectuate sau renuntare la modificarile efectuate cu revenire la vechile valori), sau se poate opta pentru cautarea in baza de date a altor spitale salvate anterior ca spitale de lucru in vederea incarcarii lor in macheta principala spre vizualizare, editare sau stergere (butonul Cauta...).

Daca s-a optat pentru cautarea in baza de date a unor spitale, ori de cate ori acest buton este activ, se deschide o macheta de selectie in care vor fi afisate toate spitalele deja setate ca spitale de lucru (butonul Cauta...). Prin dublu click pe un spital afisat, se obtine incarcarea acestuia in macheta principala, inchiderea machetei de selectie, si se poate opta pentru una din operatiile descrise mai sus: editare, stergere, adaugare spitale de lucru noi.

Fig4. Macheta Selectie spitale de lucru

Observatie: Operatiile setare spitale de lucru, sectii asociate spitalelor si medici asociati spitalelor sunt disponibile doar utilizatorului care a accesat aplicatia folosind contul cu permisiuni de admininistrare (DRG_Admin).


Setare lista sectii

Gestionarea sectiilor in spitalele care colecteaza date

Informatiile legate de sectiile pentru care se colecteaza date se gestioneaza prin intermediul acestei operatii. Inainte de a se incepe colectarea foilor de observatie este necesara efectuarea acestei operatii.

Denumirea sectiilor si codul acestora nu se completeaza la nivelul spitalelor, ci se aleg dintr-o lista care contine toate sectiile posibile. Singura informatie care trebuie specificata este numarul sectiei si eventual daca aceasta sectie se seteaza ca implicita in macheta de colectare a foilor de observatie.

Manipularea sectiilor de lucru trebuie sa respecte o serie de reguli:

  • Nu se poate insera in baza de date aceeasi sectie, cu acelasi numar, la acelasi spital, de mai multe ori;
  • Nu se poate sterge o sectie de lucru pentru care s-au completat foi de observatie;
  • O sectie de lucru odata setata poate fi modificata atat timp cat nu au fost completate foi de observatie, alegand in locul sau alta sectie sau alt numar, doar daca noua sectie specificata aleasa (sectie si numar) nu exista deja specificata.

Nerespectarea acestor reguli este soldata cu aparitia unui mesaj de eroare care identifica eroarea comisa.

Macheta pentru manipularea acestor informatii se prezinta astfel:

Fig1. Macheta Selectie/Adaugare/Editare/Stergere informatii sectii de lucru

In momentul deschiderii sale, macheta este pregatita pentru efectuarea a doua operatii distincte:

  1. Adaugarea de informatii noi, prin completarea controalelor de editare disponibile.
  2. Cautarea in baza de date a informatiilor legate de sectiile deja setate (click pe butonul Cauta...).

Daca s-a optat pentru prima operatie, imediat dupa completarea unui control cu informatie, se dezactiveaza posibilitatea de cautare in baza, butonul Cauta... devenind inactiv. In schimb devin active butoanele Salveaza si Renunta, oferind utilizatorului posibilitatea de a salva datele nou intreoduse (click pe butonul Salveaza) sau a renunta la introducerea acestor date (click pe butonul Renunta). Salvarea datelor in baza de date va avea loc daca nu sunt incalcate regulile specificate mai sus.
Inainte de a opta pentru una din cele doua posibilitati, macheta se prezinta astfel:

Fig2. Macheta Selectie/Adaugare/Editare/Stergere informatii sectii de lucru inainte de Salvare|Renuntare

Daca s-a optat pentru renuntarea la informatiile introduse, macheta revine la starea initiala din figura 1.
Daca s-a optat pentru salvarea informatiilor in baza, iar aceste informatii au fost salvate cu succes, macheta trece intr-o noua stare prezentata mai jos.

Fig3. Macheta Selectie/Adaugare/Editare/Stergere informatii sectii de lucru dupa salvarea datelor

In acest moment se poate opta pentru setarea altor sectii ca sectii de lucru, adaugandu-le in baza de date (butonul Adauga...; macheta de informatii revine la starea din figura 1, pregatita pentru adaugare), se poate opta pentru stergerea acestei sectii setata ca sectie de lucru (butonul Sterge; inainte de stergerea propriu-zisa a sectiei din baza de date se solicita inca o data confirmarea acestei operatii, avand in vedere ca se poate apasa din greseala pe acest buton, iar stergerea datelor este o operatie asupra careia nu se mai poate reveni), se poate opta pentru editarea datelor afisate pe ecran (modificand valorile din controalele de editare disponibile - imediat dupa modificarea valorilor se activeaza din nou optiunile de salvare | renuntare care de aceasta data au semnificatia de salvare a modificarilor efectuate sau de renuntare la modificarile efectuate cu revenire la vechile valori), sau se poate opta pentru cautarea in baza de date a altor sectii salvate anterior ca sectii de lucru in vederea incarcarii lor in macheta principala spre vizualizare, editare sau stergere (butonul Cauta...).

Daca s-a optat pentru cautarea in baza de date a unor sectii, ori de cate ori acest buton este activ, se deschide o macheta de selectie in care vor fi afisate toate sectiile deja setate ca sectii de lucru pentru spitalul de lucru selectat (butonul Cauta...). Prin dublu click pe un sectie afisata, se obtine incarcarea acesteia in macheta principala, inchiderea machetei de selectie, si se poate opta pentru una din operatiile descrise mai sus: editare, stergere, adaugare sectii de lucru noi.

Fig4. Macheta Selectie sectii de lucru

Observatie: Operatiile setare spitale de lucru, sectii asociate spitalelor si medici asociati spitalelor sunt disponibile doar utilizatorului care a accesat aplicatia folosind contul cu permisiuni de admininistrare (DRG_Admin).


Setare lista medici

Gestionarea medicilor in spitalele care colecteaza date

Informatiile legate de medicii disponibili la completarea foilor de observatie se gestioneaza prin intermediul acestei operatii. Inainte de a se incepe colectarea foilor de observatie este necesara efectuarea acestei operatii.

Informatiile referitoare la medici includ codul de parafa al medicului (poate contine maxim 7 caractere ), numele complet al medicului precum si specialitatea acestuia.

Manipularea medicilor trebuie sa respecte o serie de reguli:

  • Nu se poate insera in baza de date un medic cu acelasi cod de parafa, la acelasi spital, de mai multe ori;
  • Nu se poate sterge un medic specificat intr-o foaie de observatie;
  • Un medic odata inserat in baza poate fi modificat atat timp cat nu au fost completate foi de observatie, alegand alta specialitate, modificand codul de parafa sau numele, doar daca noile modificari nu incalca constrangerea de cod de parafa unic la nivelul spitalului .

Nerespectarea acestor reguli este soldata cu aparitia unui mesaj de eroare care identifica eroarea comisa.

Macheta pentru manipularea acestor informatii se prezinta astfel:

Fig1. Macheta Selectie/Adaugare/Editare/Stergere informatii medici

In momentul deschiderii sale, macheta este pregatita pentru efectuarea a doua operatii distincte:

  1. Adaugarea de informatii noi, prin completarea controalelor de editare disponibile.
  2. Cautarea in baza de date a informatiilor legate de medicii deja inserati (click pe butonul Cauta...).

Daca s-a optat pentru prima operatie, imediat dupa completarea unui control cu informatie, se dezactiveaza posibilitatea de cautare in baza, butonul Cauta... devenind inactiv. In schimb devin active butoanele Salveaza si Renunta, oferind utilizatorului posibilitatea de a salva datele nou introduse (click pe butonul Salveaza) sau a renunta la introducerea acestor date (click pe butonul Renunta). Salvarea datelor in baza de date va avea loc daca nu sunt incalcate regulile specificate mai sus.
Inainte de a opta pentru una din cele doua posibilitati, macheta se prezinta astfel:

Fig2. Macheta Selectie/Adaugare/Editare/Stergere informatii medici inainte de Salvare|Renuntare

Daca s-a optat pentru renuntarea la informatiile introduse, macheta revine la starea initiala din figura 1.
Daca s-a optat pentru salvarea informatiilor in baza, iar aceste informatii au fost salvate cu succes, macheta trece intr-o noua stare prezentata mai jos.

Fig3. Macheta Selectie/Adaugare/Editare/Stergere informatii medici dupa salvarea datelor

In acest moment se poate opta pentru adaugarea altor medici (butonul Adauga...; macheta de informatii revine la starea din figura 1, pregatita pentru adaugare), se poate opta pentru stergerea acestui medic (butonul Sterge; inainte de stergerea propriu-zisa a medicului din baza de date se solicita inca o data confirmarea acestei operatii, avand in vedere ca se poate apasa din greseala pe acest buton, iar stergerea datelor este o operatie asupra careia nu se mai poate reveni), se poate opta pentru editarea datelor afisate pe ecran (modificand valorile din controalele de editare disponibile - imediat dupa modificarea valorilor se activeaza din nou optiunile de salvare | renuntare care de aceasta data au semnificatia de salvare a modificarilor efectuate sau de renuntare la modificarile efectuate cu revenire la vechile valori), sau se poate opta pentru cautarea in baza de date a altor medici salvati anterior in vederea incarcarii lor in macheta principala spre vizualizare, editare sau stergere (butonul Cauta...).

Daca s-a optat pentru cautarea in baza de date a unor medici, ori de cate ori acest buton este activ, se deschide o macheta de selectie in care vor fi afisati toti medicii din spitalul de lucru selectat, putand opta pentru filtrari suplimentare, care vor afisa doar medicii cu o anumita specialitate sau cu un anumit cod (butonul Cauta...). Prin dublu click pe un medic afisat, se obtine incarcarea acestuia in macheta principala, inchiderea machetei de selectie, si se poate opta pentru una din operatiile descrise mai sus: editare, stergere, adaugare medici noi.

Fig4. Macheta Selectie medici

Observatie: Operatiile setare spitale de lucru, sectii asociate spitalelor si medici asociati spitalelor sunt disponibile doar utilizatorului care a accesat aplicatia folosind contul cu permisiuni de admininistrare (DRG_Admin).


FOCG

Gestionarea foilor de observatie clinica generala

Macheta principala a aplicatiei permite inregistrarea setului minim de date la nivel de pacient (SMDP), conform prevederilor ordinului Ministrului Sanatatii Nr. 29 din 2003, cu modificarile si completarile specificate in ordinul 1623 din 2004. Macheta permite inregistrarea foilor de observatie noi, editarea foilor de observatie salvate anterior in baza de date, dar si analiza foilor de observatie in urma proceselor de grupare si validare.

Foile de observatie clinica generala pot fi completate numai dupa specificarea spitalelor de lucru, a sectiilor si medicilor din aceste spitale.

Manipularea datelor din setul minim de date la nivel de pacient trebuie sa respecte urmatoarele reguli:

  • Nu este permisa existenta unei FOCG cu acelasi numar si data externare, completata de mai multe ori pentru aceeasi sectie (cod sectie si numar) in acelasi spital. Toate referirile la o FOCG se fac specificand spitalul, sectia (cod si numar), numarul si data externarii trecute pe foaie. Campul Caz_ID asigura in continuare unicitatea foilor de observatie, dar el este folosit doar ca identificator intern, si este generat pe parcursul completarii foilor de observatie.
  • Componenta campului Caz_ID este urmatoarea:
    1. 6 caractere care identifica codul spitalului (cod INCDS);
    2. 4 caractere care identifica codul sectiei;
    3. 2 caractere care identifica numarul sectiei (daca numarul sectiei nu este format din 2 caractere, ci doar din unul, ultimul caracter este automat "_");
    4. 6 caractere care identifica numarul foii de observatie (daca numarul foii nu este format din 6 caractere, ultimele caractere sunt automat "_");
    5. 10 caractere care identifica data internarii;
    6. 19 caractere care identifica momentul inceperii completarii foii de observatie
  • Campul Caz_ID se genereaza la inserarea foii de observatie in baza de date si NU se mai modifica pe parcursul editarii acesteia.
  • Urmatoarele campuri sunt obligatoriu de completat:
    • Spital; se alege din lista.
    • Sectie externare; este propusa automat o valoare corespunzatoare proprietatii Implicit a sectiilor definite, in cazul in care s-a propus o sectie implicita, sau se poate alege din lista valoarea dorita. In momentul in care s-a optat pentru o sectie, se dezactiveaza posibilitatea de a alege alta valoare in campul Spital.
    • Data si ora internarii;
    • Data si ora externarii;
    • Numarul foii de observatie; se permite specificarea unui numar pe oricate caractere, dar se genereaza un avertisment in care acest numar depaseste 6 caractere;
    • Data nastere;
    • Sex; se alege o valoare din lista.
    • Statut pacient; se alege o valoare din lista. Daca s-a optat pentru un pacient "Asigurat CNAS", devine obligatoriu de specificat si tipul casei de asigurare, alegand o valoare din aceasta lista. Daca valoarea aleasa pentru tipul casei de asigurare este "Judeteana", trebuie specificat si judetul de apartenenta al casei locala de sanatate.
    • Tip internare; se alege o valoare din lista.
    • Stare externare; se alege o valoare din lista.
    • Tip externare; se alege o valoare din lista.
    • Medicul curant; se alege o valoare din lista. Specialitatea medicului va fi afisata automat.
    • Campul diagnostic principal COD1; se poate completa in casuta de editare sau cauta in baza de date prin intermediul unei forme de selectie.
    • O linie in tabela cu transferuri cu sectia de externare, data internare, data externare si numarul de zile pe acea sectie, in cazul in care pacientul a stat intr-o singura sectie pe perioada internarii, sau mai multe linii care sa indice transferul intre sectii in cadrul spitalului pe perioada spitalizarii.
      Daca se completeaza mai multe linii in tabela cu transferuri intre sectii, liniile trebuie completate respectand evolutia cronologica a transferului intre sectii, si, in plus, trebuie respectate alte reguli suplimentare. Astfel pentru prima linie, Data Internare din foaie de observatie trebuie sa coincida cu Data Internare de pe aceasta linie. Liniile care urmeaza trebuie sa aiba fiecare data internare egala cu data externare a liniei precedente. Iar pentru ultima linie este necesar ca sectia (numar si cod) si data externare sa coincida sectia de externare (cod si numar) si data externare din antetul foii de observatie.
      In plus, totalul numarului de zile specificat in acest tabel trebuie sa fie egal cu numarul de zile rezultat din diferenta dintre data externare si data internare specificate in antetul foii de observatie.
  • Alte campuri incluse in SMDP pot fi completate, daca este cazul:
    • Numele, prenumele si codul numeric personal al pacientului, judetul si localitatea acestuia; Codul numeric personal trebuie sa fie o expresie numerica formata din 13 caractere, pentru a putea fi interpretat ca CNP corect.
    • Informatii legate de diagnosticul la internare si diagnosticul principal COD 2. Acesta din urma poate fi ales doar ca o valoare specifica unui diagnostic principal COD 1 ales anterior.
    • Un numar dorit de diagnostice secundare in tabelul aferent.
    • Informatii legate de interventia chirurgicala principala (interventia chirurgicala in sine, data in care a avut loc, si alti doi medici care au participat). Informatia despre interventia chirurgicala principala trebuie completata in totalitate, nefiind permisa completarea unei astfel de informatii decat prin specificarea completa a codulului de interventie, data in care a avut loc si medicul operator I. In plus, campul Medic operator II poate fi specificat doar daca informatiile complete despre interventia chirurgicala au fost completate.
    • Informatii legate de alte proceduri efectuate, in tabelul aferent, cu specificarea, daca este cazul, a unui numar mai mare de 1 in campul Cantitate, pentru fiecare procedura. Prezenta unei cantitati nule sau aparitia aceleasi proceduri pe mai multe linii conduce la aparitia unui mesaj de eroare in acest sens.
  • In plus o serie de verificari asigura consistenta datelor introduse:
    • Data si ora internarii, Data si ora externarii NU trebuie sa fie mai mari decat data curenta (setata in calculator) - valori permise in intervalul 01/01/1800---31/12/2050;
    • Data nastere NU trebuie sa fie mai mare dacat Data Internare valori permise in intervalul 01/01/1800---31/12/2050;
    • Data interventie chirurgicala principala trebuie sa fie cuprinsa in intervalul [Data Internare, DataExternare] - valori permise in intervalul 01/01/1800---31/12/2050;
    • O foaie de observatie nou introdusa are setat campul Stare inregistrare la valoarea "Normala";
    • La incheierea procesului de editare a unei foi de observatie salvate anterior, daca aceasta foaie de observatie nu a fost supusa deja proceselor de grupare si validare, campul Stare inregistrare trebuie pastrat la valoarea "Normala" sau trecut in valoarea "Anulata". Orice alte valori ale acestui camp nu sunt permise;
    • La incheierea procesului de editare a unei foi de observatie salvate anterior, daca aceasta foaie de observatie a fost supusa deja proceselor de grupare si validare, campul Stare inregistrare trebuie sa contina una din valorile: "Modificata", "Anulata" sau "Cerere validare". Valoarea "Normala" in acest caz nu mai este permisa.
  • Zona "Clasificare" a machetei contine informatii care NU se completeaza la nivelul spitalului, dar care pot fi foarte utile dupa operatia de Import a codurilor DRG. Astfel se pot vizualiza regulile clinice si financiare incalcate, sau valoarea relativa si tariful la nivelul spitalului.
  • Campul Finalizat semnifica ca foaia de observatie va fi luata in calcul in procesul de Export catre biroul DRG si, din momentul in care a fost selectat, toate informatiile editate ulterior sunt inscrise intr-un jurnal de modificari.
  • Campul Selectat pentru export semnifica ca doar foaia de observatie in cauza impreuna cu foile similare vor fi selectate pentru export. Aceasta operatie permite exportarea unui numar limitat de foi, de regula cu probleme, pentru re-grupare si re-validare.
    Atentie: o foaie de observatie marcata ca "Selectata pentru export" nu va fi exportata atat timp cat nu va fi marcata si ca "Finalizata".
  • Campul Stare Validare nu va avea nici o valoare afisata pentru o foaie de observatie care nu a fost niciodata supusa procesului de grupare si validare la INCDS. Dupa operatia de Import coduri DRG, pentru fiecare foaie de observatie supusa procesului de grupare si validare, acest camp va afisa una din cele doua valori: "Validat" sau "NeValidat".

Nerespectarea acestor reguli este soldata cu aparitia unui mesaj de eroare care identifica eroarea comisa.

Macheta pentru manipularea acestor informatii se prezinta astfel:

Fig1. Macheta Selectie/Adaugare/Editare/Stergere foi de observatie clinica generala

Prima sectiune a acestei machete permite colectarea datelor pasaportale despre pacient. Inregistrarea datelor in aceasta sectiune presupune completarea unor valori in controalele de editare sau alegerea unor valori din listele predefinite (vezi operatia Completare date).
A doua sectiune permite completarea diagnosticului la internare, a diagnosticelor la externare (Cod1 - Cod2) si a diagnosticelor secundare in tabelul alocat in acest scop. Diagnosticul principal Cod1 este un camp obligatoriu de completat in aceasta sectiune. Campurile Diagnostic la internare, Diagnostic principal - Cod1 si Diagnostic principal - Cod2 se pot completa, daca se cunoaste codul acestor diagnostice, sau se pot alege dintr-o lista, daca se apasa pe butonul din stanga acestor controale. Diagnosticele secundare se completeaza linie cu linie, folosind pentru adaugare, stergere linii, revenire asupra stergerii unor linii butoanele din partea dreapta, sus, a tabelului. In fiecare linie a tabelului se completeaza doar codul diagnosticului, similar ca mai sus, denumirea fiind afisata automat. Celelalte campuri din linie nu se completeaza, ele fiind disponibile pentru fiecare foaie de observatie numai dupa operatia Import coduri DRG. Pentru detalii suplimentare se poate consulta operatia Completare date.

Fig2. Macheta Selectie/Adaugare/Editare/Stergere foi de observatie clinica generala
Diagnostice

A treia sectiune a acestei machete permite completarea informatiilor privind interventia chirurgicala principala si a tututor celorlalte proceduri. Informatiile legate de interventia chirurgicala principala nu sunt obligatorii, dar daca se completeaza aceasta informatie, trebuie completate codul interventiei, data interventiei si medicul operator I. Interventia chirurgicala principala si celelate proceduri se pot completa, daca se cunoaste codul lor, sau se pot alege dintr-o lista, daca se apasa pe butonul din stanga acestor controale. Procedurile se completeaza linie cu linie, folosind pentru adaugare, stergere linii, revenire asupra stergerii unor linii butoanele din partea dreapta, sus, a tabelului. In fiecare linie a tabelului se completeaza doar codul procedurii, similar ca mai sus, denumirea fiind afisata automat. Campul Cant. va fi afisat automat cu o valoare 1, dar poate fi editat corespunzator numarului de proceduri efectuate. Celelalte campuri din linie nu se completeaza, ele fiind disponibile pentru fiecare foaie de observatie numai dupa operatia Import coduri DRG. Pentru detalii suplimentare se poate consulta operatia Completare date.

Fig3. Macheta Selectie/Adaugare/Editare/Stergere foi de observatie clinica generala
Proceduri

A patra sectiune a acestei machete permite completarea informatiilor privind transferurile intre sectii in interiorul spitalului. Regulile de completare a acestui tabel au fost enumerate la inceputul paginii. In plus, valorile permise pentru campurile Data internare si Data externare sunt cuprinse in intervalul 01/01/1900--31/12/2050. Transferurile intre sectii se completeaza linie cu linie, folosind pentru adaugare, stergere linii, revenire asupra stergerii unor linii butoanele din partea dreapta, sus, a tabelului. In fiecare linie a tabelului se completeaza codul sectiei, ales din lista, numarul sectiei fiind afisat automat. De asemenea, trebuie completate si data internare, data externare in sectia respectiva, precum si numarul de zile de sedere in acea sectie. Pentru detalii suplimentare se poate consulta operatia Completare date.

Fig4. Macheta Selectie/Adaugare/Editare/Stergere foi de observatie clinica generala
Transferuri

Ultima sectiune a acestei machete permite vizualizare informatiilor cu privire la procesarea foii de observatie in cadrul proceselor de grupare si validare efectuate la INCDS. Sunt afisate informatii legate de clasificarea foii de observatie in grupe de diagnostic si valoarea relativa, dar si informatii deosebit de utile spitalelor in cazul invalidarii foii de observatie in cauza. Astfel operatorii pot lua la cunostinta despre regula clinica sau financiara incalcata si motivele care au dus la acest fapt si identifica si efectua corectii, daca este cazul, spre trimitere foaia de observatie in cauza spre revalidare.

Fig5. Macheta Selectie/Adaugare/Editare/Stergere foi de observatie clinica generala
Clasificare

In momentul deschiderii sale, macheta este pregatita pentru efectuarea a 2 operatii distincte:

  1. Adaugarea de informatii noi, prin completarea controalelor de editare disponibile.
  2. Cautarea in baza de date a informatiilor legate de foile de observatie deja inserate (click pe butonul Cauta...).

Daca s-a optat pentru prima operatie, imediat dupa completarea unui control cu informatie, se dezactiveaza posibilitatea de cautare in baza, butonul Cauta... devenind inactiv. In schimb devin active butoanele Salveaza si Renunta, oferind utilizatorului posibilitatea de a salva datele nou introduse (click pe butonul Salveaza) sau de a renunta la introducerea acestor date (click pe butonul Renunta). Salvarea datelor in baza de date va avea loc daca nu sunt incalcate regulile specificate mai sus.
Inainte de a opta pentru una din cele doua posibilitati, macheta se prezinta astfel:

Fig6. Macheta Selectie/Adaugare/Editare/Stergere foi de observatie clinica generala inainte de Salvare|Renuntare

Daca s-a optat pentru renuntarea la informatiile introduse, macheta revine la starea initiala din figura 1.
Daca s-a optat pentru salvarea informatiilor in baza, iar aceste informatii au fost salvate cu succes, macheta trece intr-o noua stare prezentata mai jos.

Fig7. Macheta Selectie/Adaugare/Editare/Stergere foi de observatie clinica generaladupa salvarea datelor

In acest moment se poate opta pentru adaugarea altor foi de observatie(butonul Adauga...; macheta de informatii revine la starea din figura 1, pregatita pentru adaugare), se poate opta pentru editarea datelor afisate pe ecran (modificand valorile din controalele de editare disponibile - imediat dupa modificarea valorilor se activeaza din nou optiunile de salvare | renuntare care de aceasta data au semnificatia de salvare modificari efectuate sau renuntare la modificarile efectuate cu revenire la vechile valori), sau se poate opta pentru cautarea in baza de date a altor foi de observatie salvate anterior in vederea incarcarii lor in macheta principala spre vizualizare sau editare (butonul Cauta...).

Daca s-a optat pentru cautarea in baza de date a unor foi de observatie, ori de cate ori acest buton este activ, se deschide o macheta de selectie in care vor fi afisate foile de observatie care indeplinesc criteriul definit (butonul Cauta...). Prin dublu click pe o foaie de observatie afisata, se obtine incarcarea acesteia in macheta principala, inchiderea machetei de selectie, si se poate opta pentru una din operatiile descrise mai sus: editare sau adaugare foi de observatie noi.

Fig4. Macheta Selectie foi de observatie clinica generala

Observatie: Asupra foilor de observatie clinica generala incarcate din baza in vederea procesului de editare se fac verificari suplimentare la salvarea modificarilor, in vederea asigurarii ca nici un alt utilizator al aplicatiei nu efectueaza modificari in acelasi timp.


Administrare

Administrarea aplicatiei (gestionare utilizatori) si a bazei de date (rularea unor proceduri adminsitrative pe baza de date) se face utilizand meniul Administrare.

  • Gestionarea utilizatori (meniul Administrare\Utilizatori).
    Vezi operatia Gestionare utilizatori.
  • Creare copii de siguranta a bazei de date si restaurare baza de date dupa astfel de copii(meniul Administrare\Backup-Restore).
    Vezi operatia Backup - Restore baza de date.
  • Rularea anumitor proceduri de actualizare baza de date conform unor modificari care ar putea aparea in timp(meniul Administrare\Rulare scripturi INCDS).
    Vezi operatia Rulare proceduri actualizare.


BackupRestore

Creare copii de siguranta in baza de date si restaurare baza de date dupa aceste copii

Aceaste operatii permit crearea unor copii de siguranta pentru baza de date si folosirea acestor copii de siguranta pentru restaurarea bazei de date. Operatiile sunt disponibile doar utilizatorului care a accesat aplicatia folosind contul cu permisiuni de admininistrare (DRG_Admin).

Este necesar ca aceste operatii sa fie efectuate utilizand aplicatia instalata doar pe calculatorul care este si server de baze de date, deoarece operatiile in sine nu se poate efectua decat utilizand unitati de disc locale, si nu de retea.

Macheta care permite executarea acestor aplicatii se prezinta ca mai jos. La deschiderea sa, aceasta macheta este setata implicit pentru operatia "Backup" - Creare copie de siguranta.

Fig1. Macheta Backup | Restore baza de date
operatie Backup

Calea in care sunt salvate aceste copii de siguranta este dictata de calea in care a fost instalata aplicatia, in aceasta cale adaugandu-se in timpul procesului de instalare catalogul Backup pentru acest scop. Procesul de backup este un proces care nu dureaza foarte mult timp, rezultatul acestui proces fiind copia de siguranta creata in acest catalog, care se recomanda a fi pastrata pe discuri compact.

Frecventa de efectuare a acestei operatii este dictata de frecventa de utilizare a aplicatiei pentru colectare date. Se pot face copii de siguranta si zilnic, dar si la interval de o saptamana.

Operatia de backup a bazei de date se poate face si in timp ce alti utilizatori sunt conectati la aplicatie si colecteaza date. Insa este bine ca aceasta operatie sa se efectueze cand nu mai sunt utilizatori conectati la baza de date.

Daca se doreste insa restaurarea bazei de date pornind de la o copie a sa, se alege optiunea "Restaurare", butonul prin intermediul careia se efectueaza operatia schimbandu-si semnificatia din "Backup" in "Restaurare".

Fig1. Macheta Backup | Restore baza de date
operatie Restaurare

In plus este necesara si alegerea unui fisier pe baza caruia sa se faca restaurarea, de preferinta ultimul ca data. Nespecificarea unui fisier impiedica realizarea acestei operatii.
Operatia de restaurare a bazei de date este proiectata sa opreasca conexiunile celorlalti potentiali utilizatori ai aplicatiei, deoarece numai asa se poate executa. Daca alti utilizatori colectau date in acel moment, in momentul in care vor incerca sa trimita date in baza sau sa aduca date din baza vor receptiona un mesaj de eroare care va inchide aplicatia lor.
De aceea este obligatoriu ca aceasta operatie sa se efectueze dupa ce administratorul s-a asigurat in prealabil ca nu exista si alti utilizatori ai aplicatiei. In plus, dupa incheierea operatiei de restaurare, aplicatia se va inchide, putand fi ulterior repornita pentru a se putea realiza conexiunea la noua baza de date.

Aceasta operatie de restaurare este o operatie care poate dura mai mult timp, in functie de marimea bazei de date din cadrul copiei de siguranta. De aceea este necesar sa asteptati incheierea operatiei, sau aparitia unui mesaj de eroare care impiedica acest lucru.

Se intentioneaza ca in foarte scurt timp aceasta interfata sa fie completata cu posibilitatea de a afisa administratorului si utilizatorii care folosesc aplicatia in acel moment (numele calculatoarelor din retea care folosesc aplicatia).


Scripturi

Rulare proceduri de actualizare baza de date

Prin intermediul aceste machete se pot rula diferite actualizari in baza de date a spitalului, actualizari care tin de introducerea unui nou articol intr-unul din nomenclatoarele aplicatiei, modificarea unui astfel de cod etc, dar si eventuale proceduri de adminsitrare baza de date care vor fi dezvoltate ulterior la INCDS si trimise tuturor spitalelor care folosesc aceasta aplicatie.

Fisierele respective sunt stocate in catalogul "Scripturi" din calea in care a fost instalata aplicatia. Rularea unui astfel de fisier de actualizare sau care efectueaza proceduri de administrare a bazei de date poate necesita un timp mai mare sau mai scurt, in functie de complexitatea procesului.

Fig.1 Rulare fisiere de actualizare | administrare baza de date

Singurul lucru necesar este selectarea fisierului indicat la momentul necesar, si rularea acestuia prin apasarea butonului "Rulare script".

In functie de activitatea desfasurata pe parcursul acestui proces ar putea fi necesara sau nu solicitarea celorlalti utilizatori sa inchida aplicatia.

Observatie: este recomandat ca dupa acest proces sa efectuati si o copie de siguranta a bazei de date, astfel ca, in cazul unei caderi a sistemului sa se poata restaura baza de date pe baza acelei copii, continand insa si modificarile aduse de ultimele actualizari prin intermediul rularii acestor fisiere script.

Observatie: Aceasta operatie nu este disponibila decat utilizatorului care a accesat aplicatia folosind contul cu permisiuni de admininistrare (DRG_Admin). In plus este necesar ca aceasta operatie sa fie efectuata utilizand aplicatia instalata doar pe calculatorul care este si server de baze de date.


Utilizatori

Gestionarea utilizatorilor

Informatiile legate de utilizatorii aplicatiei se gestioneaza prin intermediul acestei operatii. Imediat dupa instalarea aplicatiei este disponibil un singur utilizator, DRG_Admin, cu parola drgadmin. Acest utilizator este configurat cu drepturi depline asupra aplicatiei. Numai acest utilizator are permis accesul in sectiunile de administrare a serverului de baze de date si a bazei de date propriu-zisa, poate crea, edita, sterge utilizatori, poate efectua operatiile de export si import date. In spitalele in care se introduc date doar de catre un singur operator, se poate pastra doar acest cont de utilizator, insa in spitalele in care datele se introduc de mai multi operatori, de pe statii de lucru diferite se recomanda crearea de conturi de utilizator de catre administratorul aplicatiei pentru fiecare utilizator in parte, si, mai important, administratorul sa modifice parola contului de administrator, pentru a impiedica alti operatori sa efectueze operatii pentru care nu sunt autorizati.
Utilizatorul DRG_Admin nu poate si sters.

Informatiile referitoare la utilizatori includ numele utilizatorului (poate contine maxim 50 caractere ) si parola acestuia (un sir de maxim 10 caractere).

Manipularea utilizatorilor trebuie sa respecte o serie de reguli:

  • Nu se pot insera in baza de date mai multi utilizatori cu acelasi nume;
  • Nu se poate sterge un utilizator care a completat o foaie de observatie;
  • Un utilizator odata inserat in baza poate fi modificat doar daca noile modificari nu incalca constrangerea de nume de utilizator unic.

Nerespectarea acestor reguli este soldata cu aparitia unui mesaj de eroare care identifica eroarea comisa.

Macheta pentru manipularea acestor informatii se prezinta astfel

Fig1. Macheta Selectie/Adaugare/Editare/Stergere informatii utilizatori

In momentul deschiderii sale, macheta este pregatita pentru efectuarea a 2 operatii distincte:

  1. Adaugarea de informatii noi, prin completarea controalelor de editare disponibile.
  2. Cautarea in baza de date a informatiilor legate de utilizatorii deja inserati (click pe butonul Cauta...).

Daca s-a optat pentru prima operatie, imediat dupa completarea unui control cu informatie, se dezactiveaza posibilitatea de cautare in baza, butonul Cauta... devenind inactiv. In schimb devin active butoanele Salveaza si Renunta, oferind utilizatorului posibilitatea de a salva datele nou introduse (click pe butonul Salveaza) sau a renunta la introducerea acestor date (click pe butonul Renunta). Salvarea datelor in baza de date va avea loc daca nu sunt incalcate regulile specificate mai sus.
Inainte de a opta pentru una din cele doua posibilitati, macheta se prezinta astfel

Fig2. Macheta Selectie/Adaugare/Editare/Stergere informatii utlizatori inainte de Salvare|Renuntare

Informatiile din campurile Parola si Verificare parola trebuie sa coincida. Butonul din dreapta campului Parola afiseaza alaturi informatia reala din campul Parola, pentru a evita tiparirea unei informatii in campul Parola care nu mai coincide cu informatia din campul Verificare parola. O apasare pe acest buton afiseaza informatia reala din campul Parola iar inca o afisare va ascunde aceasta parola.

Daca s-a optat pentru renuntarea la informatiile introduse, macheta revine la starea initiala din figura 1.
Daca s-a optat pentru salvarea informatiilor in baza, iar aceste informatii au fost salvate cu succes, macheta trece intr-o noua stare prezentata mai jos.

Fig3. Macheta Selectie/Adaugare/Editare/Stergere informatii utilizatori dupa salvarea datelor

In acest moment se poate opta pentru adaugarea altor utilizatori (butonul Adauga...; macheta de informatii revine la starea din figura 1, pregatita pentru adaugare), se poate opta pentru stergerea acestui utilizator (butonul Sterge; inainte de stergerea propriu-zisa a medicului din baza de date se solicita inca o data confirmarea acestei operatii, avand in vedere ca se poate apasa din greseala pe acest buton, iar stegerea datelor este o operatie asupra careia nu se mai poate reveni), se poate opta pentru editarea datelor afisate pe ecran (modificand valorile din controalele de editare disponibile - imediat dupa modificarea valorilor se activeaza din nou optiunile de salvare | renuntare care de aceasta data au semnificatia de salvare modificari efectuate sau renuntare la modificarile efectuate cu revenire la vechile valori), sau se poate opta pentru cautarea in baza de date a altor utilizatori salvati anterior in vederea incarcarii lor in macheta principala spre vizualizare, editare sau stergere (butonul Cauta...).

Daca s-a optat pentru cautarea in baza de date a unor utilizatori, ori de cate ori acest buton este activ, se deschide o macheta de selectie in care vor fi afisati toti utilizatorii (butonul Cauta...). Prin dublu click pe un utilizator afisat, se obtine incarcarea acestuia in macheta principala, inchiderea machetei de selectie, si se poate opta pentru una din operatiile descrise mai sus: editare, stergere, adaugare utilizatori noi.

Fig4. Macheta Selectie utilizatori

Observatie: Operatia de gestionare utilizatori nu este disponibila decat utilizatorului care a accesat aplicatia folosind contul cu permisiuni de admininistrare (DRG_Admin).


Transfer

Transfer date

Aceasta operatie se efectueaza in doua sensuri. Pe de o parte se genereaza fisiere de tip Microsoft Access 2000 lunar si la regularizari continand foile de observatie clinica generale ce trebuie supuse procesului de grupare si validare sau anulate, prin operatia Export cu criptare catre INCDS, iar dupa aceste operatii se efectueaza importul datelor rezultate in urma proceselor de grupare si validare, prin operatia Import coduri DRG.

  • Export catre biroul DRG (meniul Transfer date\Export coduri DRG).
    Vezi operatia Export cu criptare catre INCDS.
  • Import coduri DRG (meniul Transfer date\Import coduri DRG).
    Vezi operatia Import coduri DRG.


Export

Export cu criptare catre INCDS

Aceasta operatie permite generarea fisierelor Access cu foile de observatie clinica generala colectate, nesupuse proceselor de grupare si validare, corectate in vederea retransmiterii pentru regrupare si revalidare, sau anulate in vederea anularii lor si in baza de date centralizata.

Fig1. Macheta Export foi de observatie catre INCDS

Aceste fisiere se genereaza lunar, si este indicat sa contina doar foile de observatie clinica generala colectate in luna respectiva, nesupuse proceselor de grupare si validare, si sa nu contina foi de observatie clinica generala cu data externare in alt interval de timp (luni anterioare) deoarece procesul de grupare si validare lunar ia in calcul doar foile de observatie din luna in cauza. Configurarea machetei in acest scop se face in felul urmator:

  • se selecteaza spitalul ale carui foi de observatie vor fi exportate;

  • se alege optiunea "Pacienti finalizati care indeplinesc criteriul";

  • in cadrul ferestrei "Parametrii" se completeaza intervalul in care se incadreaza data de externare a foilor de observatie (luna pentru care se exporta date);

  • parametrul Stare validare se pastreaza cu valoarea "*****Toate*****", acest lucru semnificand ca toate foile de observatie vor fi incluse in operatia de export date.

Macheta astfel configurata arata ca mai jos:

Fig2. Macheta Export foi de observatie catre INCDS
export lunar date

In momentele in care se face regularizare, se pot genera fisiere continand foile de observatie din perioada impusa de regularizare (trimestru, semestru, 9 luni, an), se pot alege spre exportare doar foile de observatie nevalidate sau nou introduse in acea perioada, sau se pot exporta doar un numar limitat de foi de observatie care sunt necesar a fi trimise spre revalidare.

Diferite posibilitati de export date pentru acest caz sunt prezentate mai jos.

Fig3. Macheta Export foi de observatie catre INCDS
export la regularizare date
export foi observatie noi sau nevalidate

Desi operatia isi atinge scopul, in aceasta versiune sunt exportate si foile de observatie deja validate, lucru care conduce la cresterea dimensiunii fisiereului exportat. Intr-o versiune ulterioara se va corecta aceasta problema.

Fig4. Macheta Export foi de observatie catre INCDS
export la regularizare date
export foi observatie nevalidate

In acest caz sunt exportate numai foile de observatie nevalidate in intervalul selectat.

Fig5. Macheta Export foi de observatie catre INCDS
export la regularizare date
export NUMAI foi observatie selectate pentru export

In aceasta situatie vor fi exportate numai foile de observatie marcate ca "Selectate pentru export", in toata baza de date, fie ca sunt foi de observatie nesupuse procesului de grupare si validare, sau sunt deja validate sau nevalidate.

Rezultatul operatiei consta intr-un fisier de tip Microsoft Access 2000, securizat, salvat in catalogul "EXPORT", creat automat in timpul procesului de instalare a aplicatiei. La finalul acestei operatii va fi afisat un mesaj care indica numarul foilor de observatie selectate din baza de date pentru export, si numarul foilor de observatie adaugate in fisierul exportat.
Cele doua numere ar trebui sa coincida, insa pot exista exceptii in care anumite inregistrari din baza de date a spitalului nu pot fi exportate in fisierul Access. In accest caz operatia de export continua cu restul foilor de observatie, ignorand acele foi de observatie.
Intr-o versiune ulterioara a aplicatiei informatii despre aceste foi de observatie cu probleme vor fi salvate pentru a putea fi identificate foarte usor si corectate problemele care sunt ridicate in timpul operatiei de export date.

Informatiile confidentiale din foile de observatie din baza de date a spitalului sunt criptate inainte de a fi incluse in fisierul exportat.

Fisierele generate in urma acestei operatii se vor cripta si transmite electronic la INCDS.

Observatie: Operatia "Export cu criptare catre INCDS" nu este disponibila decat utilizatorului care a accesat aplicatia folosind contul cu permisiuni de admininistrare (DRG_Admin).


Import

Import coduri DRG

Aceasta operatie permite completarea foilor de observatie din baza de date a spitalului cu informatii in urma procesului de grupare si validare efectuat la INCDS. Aceste informatii contin: clasificarea foii de observatie in grupe de diagnostic DRG (grupa de diagnostic, categoria majora de diagnostic, tip medical | chirurgical, valoare relativa si tarif), regulile de validare clinice si financiare eventual incalcate, coduri de validitate pentru diagnostice si interventia chirurgicala principala si alte proceduri, dar si informatia "Stare validare" a foii de observatie clinica generala.

Fig1. Macheta Import coduri DRG

Fisierele continand aceste informatii sunt receptionate electronic de la INCDS si este necesara salvarea lor in catalogul "IMPORT" creat in acest scop in timpul instalarii aplicatiei. Aceste fisiere trebuie sa fie de tip Microsoft Access 2000.

In urma acestei operatii fiecare foaia de observatie va contine atat informatiile completate la niveul spitalului, dar si informatii generate in urma proceselor de grupare si validare a sa.

Observatie: Operatia "Import coduri DRG" nu este disponibila decat utilizatorului care a accesat aplicatia folosind contul cu permisiuni de admininistrare (DRG_Admin).


Rapoarte

Macheta Permite alegerea raportului dorit pentru rulare, specificarea valorii parametrilor pentru acest raport (daca este cazul) si lansarea in executie a raportului.
In aceasta prima versiune a aplicatiei sunt disponibile un numar redus de rapoarte care pot fi rulate la nivelul spitalului. In scurt timp, dupa o analiza impreuna cu spitalele, vor fi adaugate si transmise spitalelor si alte rapoarte, corespunzator nevoii de analiza la nivelul spitalului.

Fig. 1 Configurare parametrii rapoarte in vederea rularii

Rularea unui raport este un procedeu extrem de simplu. Se selecteaza raportul dorit din cele doua cataloage ("Nomenclatoare" si "Analiza date") si, daca este cazul, in partea dreapta vor trebui specificate valori pentru parametrii acestuia. Daca se lasa necompletat un parametru, in momentul lansarii raportului in executie va fi afisat un mesaj de eroare.
Unele rapoarte nu au nevoie de nici un parametru pentru a fi rulate. In acest caz, singurul lucru care trebuie facut este apasarea butonului Raport..., care va conduce la deschiderea raportului cu informatiile dorite.

Fig. 2 Exemplu raport afisat spre vizualizare pe ecran

Raportul odata afisat pe ecran poate fi tiparit prin intermediul butonului Print, din partea stanga, sus a raportului, sau exportat intr-un fisier spre o prelucrare ulterioara. Exportul se poate face in format Microsoft Excel, Microsoft Word, Acrobat Reader. De mentionat ca in urma operatiei de export, modul de afisare a informatiilor in fisierul exportat poate fi diferit de cel din raportul in cauza.

Rapoartele disponibile in acest moment asigura:

  1. Afisarea informatiilor despre spitalele care colecteaza date (nu necesita parametrii de specificat) - Spitale de lucru;
  2. Afisarea informatiilor despre sectiile din spitalele care colecteaza date, pentru fiecare spital de lucru in parte (nu necesita parametrii de specificat) - Sectii de lucru;
  3. Afisarea informatiilor despre medicii din spitalele care colecteaza date, pentru fiecare spital de lucru in parte (nu necesita parametrii de specificat) - Medici;
  4. Afisarea informatiilor despre diagnostice disponibile (necesita specificarea parametrului Clasa diagnostic) - Diagnostice;
  5. Afisarea informatiilor despre procedurile disponibile (necesita specificarea parametrului Capitol procedura) - Proceduri;
  6. Afisarea informatiilor despre FOCG din spitalul selectat, in intervalul ales, grupate pe sectii, informatii care urmaresc foile finalizate si nefinalizate - FOCG Finalizate | Nefinalizate (sunt necesari parametrii: Spital, intervalul analizat, si valoarea campului Finalizat - pot fi afisate foile finalizate, nefinalizate sau toate). Sunt excluse foile anulate.
  7. Afisarea informatiilor despre FOCG din spitalul selectat, in intervalul ales, grupate pe sectii, informatii care urmaresc foile nesupuse proceselor de grupare si validare, validate dupa aceste procese, sau nevalidate - FOCG Nesupuse validarii | Nevalidate | Validate (sunt necesari parametrii: Spital, intervalul analizat, si valoarea campului Stare validare - pot fi afisate foile nesupuse validarii, nevalidate, validate sau toate). Sunt excluse foile anulate.
  8. Afisarea informatiilor despre FOCG anulate din spitalul selectat, in intervalul ales, grupate pe sectii, FOCG Anulate (sunt necesari parametrii: Spital si intervalul analizat);
  9. Afisarea informatiilor despre FOCG din spitalul selectat si intervalul analizat, grupate pe sectii, informatii completate cu rezultatele proceselor de grupare si validare: grupa de diagnostic (DRG), categoria majora de diagnostic (MDC), valoarea relativa si tariful - Pacienti clasificare (sunt necesari parametrii: Spital si intervalul analizat). Sunt excluse foile anulate la nivelul spitalului.

Se intentioneaza ca numarul acestor rapoarte sa creasca si sa asigure cerintele locale ale utilizatorilor.